Topic Title: Grill not getting hot
Created on March 14, 2010 at 06:22 PM

Bill

I own a legacy grill which is about 10 years old. I began having problems with low temperatures towards the fall of last year. This winter, I completely disassembled the burner and cleaned it thoroughly. I also removed the filters from the stacks and cleaned the grill pan to nearly new condition. The problem continued. The grill has always been hooked up to the larger propane tank which services the house. I tried hooking it up to a small bbq tank with the regulator it came with and I still could not get the reading on either the thermometer on the grill or a stand alone oven thermometer to read above 325 after 1 hour of being on. I have tried a variety of settings on the adjustable air inlet from a perfect blue flame to a higher flame with 1/2 yellow flame and nothing seems to improve the temperature. I waited until today (outside temp 54 degrees) to see if the cold weather was the issue (it never had been a problem before)> I know the grill and burner are as clean as a whistle. Am I overlooking something, or is the burner at the end of its life?

@ Bill

Blockage in the gas valve, possibly in the orifice?

If your burner is in one piece, it should be okay. It is most likely not getting enough gas pressure.

The air-shutter adjustment will not be effective until you get full gas flow through the burner.


Carlos

Bill--check the orifice. I did the same thing you did and it still wouldn't get hot. Holland told me how to clean out the orifice and sure enough, there was a little cobweb blocking the very tiny hole in the orifice. good luck

Bill

I guess I should have mentioned that I also disassembled the orifice and checked it out. It was clean as a whistle. Again, the flame on the burner appears to be good - I can get a perfect blue flame or change the airflow to increase the size of the flame but it will turn to more blueish yellow. Thanks for the suggestions, but I really can't seem to put my finger on this one. The grill never had a problem getting hot any time of year before (albeit it takes a little longer in the winter to get up to temperature). The burner itself appears to be in excellent over shape for its age. I'm really baffled! Does anyone have a picture of what the flame should look like?

@ Bill

Sorry, no pictures, but the flame should be 2 1/2"-3" long all around the burner. It should be mostly blue with small yellow tips. It should come out of the burner with enough pressure so that it "sqirts" out horizontally for about 3/4" before curling up. You should also hear a light "hissing" sound coming from the burner.
One other thing, if you have an early Legacy with the filters in the smoke-stacks, you probly have a slightly smaller orifice than current SS grills. You can order the current #57 orifice in the "Parts/warranty" section. Not much difference in size, but it should help.

Eric

I had the same problem. I replaced the regulator and that solved the problem.

Bill

I can't understand how the orifice could suddenly become too small after a decade of fine service. Again, I checked this carefully when I switched the supply from the house service to the smaller portable tank, using the Holland regulator I had never used before. The temperature remained nearly the same. I am going to remove the orifice again and check it, and I'll let you know what I find. I can't imagine this grill being cleaner or more checked out than I have done. Perhaps a recheck will discover some problem. I looked at every possible troubleshooting problem on this website when I first encountered the issue, including cleaning, filters, orifice, air shutter, pressure, regulators - none have solved the problem.

Anonymous

I had to order a new regulator for mine when I experienced similar heating concerns and it solved the problem.

Carl

@Bill--a rule of thumb is, with any gas cooking appliance--"if it was getting hot and now it's not, something is blocking the flow of gas". You just have to find it. Orifices don't change sizes but they can become clogged by something very small. Regulators go back, and occasionally tank valves are not right. good luck

Dan

Since you are hooked up to your house propane tank did you use copper tubing that may have gotten kinked and restricting gas flow?

Bob

Bill, I have a Legacy also and have the same problem, not heating up when the outside air tempature starts falling. I live in Kentucky and my grill works fine during the late spring too early fall. I called Holland and they are sending me a larger orifice for my grill. I am sure this will fix my problem.
Thanks
Bob

Jim

I have a six year old Tradition that allways heated good, this Spring would not get above 325. I removed the orifice then used a set of torch tip cleaners on the orifice hole. After that I went up one size with the tip cleaner and that fixed my problem. Nice blue flame with temp staying around 400.The torch tip cleaners are small needle files.
Another tip while the orifice is out is to run a brush up into the burner to brush out the rust. You can tilt the grille over to remove the rust. Do not blow up into the burner because there is a screen that will get clogged up.

Don Stephens

Not getting hot Found the cast burner head blocked with rust slag took the head off cleaned above screen and below was blocked with scale3/4 of the opening hahapa

paul

If anyone has a used SS Holland for sale please send me a email at cooper tool@windstream.net does not matter what model

charlie

I have had my stainless legacy grill for over 10 years. I was not getting any flame and the problem proved to be the regulator. I ordered a new one from Holland for the Legacy. My grill is now getting real hot very fast. It normally cooked at around 400 degrees with full gas flow. Now it is getting to over 500 degrees and I am having to turn down the gas flow. Is this normal for a Legacy or did I get the wrong regulator.

@ Bill

Are you sure that the hose/regulator you bought is a "Low pressure" hose/regulator? If by chance you bought a "High pressure" unit, you should exchange it. You can damage your grill & it can void your warranty.