You are replying to: Grill only gets to 200*
Your Name

Message Text

Enter this code before submitting.
This will help reduce the amount of SPAM we receive from programs that automatically complete these types of forms.
Topic Title: Grill only gets to 200*
Created on April 24, 2017 at 08:21 PM

corey

Had an Apex for few months. All of a sudden this weekend, go to light he grill and will only get to 200*. Also the attached Searmate will not get near as hot as it normally would. any suggestions??

Frank

Sounds like you did something to activate the regulator safety valve.

To reset, start with everything turned off, take the hose off the tank for a minute, put the hose back on the tank, turn the tank on first, then turn the grill on & light it. You should now get full gas pressure & heat. Always turn the grill off first after cooking, then turn the tank off.
Reverse order when lighting. Tank on first, then grill on & light.
You must leave pressure in the hose or the regulator will see lower pressure as a leak.

All this assumes that you are using an LP tank with a hose/regulator. If you happen to be on natural (house)gas, look for a blockage in the system.
Hope this helps.


Gary

Corey,
It would be helpful if you would respond to Frank's suggestions. I'm sure you are not the only grill owner on LP with this issue. Did it work or not?
BTW... ALL LP hose/regulators(all brands)have the federally mandated safety valve in the regulator. Blame the government for keeping you safe.