You are replying to: grill not staying hot
Your Name

Message Text

Enter this code before submitting.
This will help reduce the amount of SPAM we receive from programs that automatically complete these types of forms.
Topic Title: grill not staying hot
Created on September 2, 2008 at 01:40 PM

Teresa Alford

I had a Holland years ago and just puchased another this week. I tried grilling steaks yesterday. I preheated the grill for 30 minutes to burn off anything on the grill from manufacturing. The grill was heated to 425 degrees. I placed the steaks on the grill and used a timer based on recommendation in manual. After I placed steaks on grill, the temperature on the grill never reached over 350 degrees. I opened the grill after 10 minutes to turn the steaks and did not open again until about 20 minutes later. My steaks were finally done (medium) after about 55 minutes. Should the temperature have gotten back up to 425 degrees? Any suggestions.

@ Teresa

Without any specific info on your grill model & the type of fuel you are on, it would be difficult for anyone to help you. I reccomend you call Holland for assistance with all the info on your grill. 800-880-9766

TerryO

Teresa, I don't know who is publising the generic responses as the 1st one you recieved, but let me try to help:
First of all, 425 is perfect preheat temp. Second, depending on how long you left the lid open to put food on, you could have easily lost 100 degrees. If that is the case, and depending on how thick your steaks were, 10 minutes was way to soon to turn your steaks. Actually you really don't have to turn them at all, but who can resist? The grill will gain temp with more food on it ratehr than less. We grill 1" - 1-1/2" steaks all of the time on the Heritage and would not even consider turning, let alone lookinig at them for at least 20 minutes. A good med. rare 1" steak will take at least 30-40 minutes depending on the outside temp.

Hope all of this helps!

TerryO


StaffordP

The grill & fuel info is critical to correctly diagnose the problem.
The grill models prior to the recently discontinued
LS models would max out at approx 400/425 degrees, so if it is an older model the grill is functioning normally.
However all LS series & later models typically preheat to about 500 degrees or a bit hotter. If the lady purchased the grill in question this week, it is more likely a newer model which is not getting to full temperature. She needs to call Holland with all the info so they can help.

Tom Wright

I had the same problem i checked everything.Finally i went to Lowes and bought a new hose and regulator for 20.00 now my grill works better than it did when i got it.Gets up to 375 degrees in 10 min.